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Document Revisions

0 2020-07-27 | Initial Release

1 2020-08-07 | Added DVR-LX®, RM-OTAP File Type Support

2 2020-10-14 | Added Helpful Hints

2.1 2020-11-20 | Updated DVR reference to VR, Updated support for FW-LMR

3 2020-02-24 | Added Helpful Hints: FW Compatibility, Enhancements

Clarification of license type support- now included RM-OTAP license
3.1 2020-08-18 | Updated information about saving DCD files and bundling license
3.2 2021-10-13 | Addition of How to Update VR ID, Replacing a VR, Overwriting
Temporary Config/FW Update

4.1 2022-01-27 | Feature License Notes information added
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Proprietary Statement

© 2022 Futurecom Systems Group ULC.
All Rights Reserved

Futurecom, PDR8000®, DVR-LX®, the Futurecom Logo and the Stylized FC logo are
registered trademarks of Futurecom Systems Group, ULC. All other trademarks are the
property of their respective owner.

This document is provided as is. This document may contain technical inaccuracies or
typographical errors. Futurecom is not responsible for any changes made from original
format.

Futurecom Systems Group ULC. reserves the right to make changes or improvements to
the equipment, software or specification described in this document at any time and
without prior notice. These changes will be incorporated in the new releases of this
document.

Futurecom Systems Group ULC. waives responsibility for any labour, materials or costs
incurred by any party as a result of using this document.

MOTOROLA, MOTO, MOTOROLA SOLUTIONS and the Stylized M Logo are
trademarks or registered trademarks of Motorola Trademark Holdings, LLC and are used
under license. All other trademarks are the property of their respective owners.
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1. Over the Air Programming via Radio
Management

Over the Air Programming via Radio Management (RM-OTAP) provides the radio
technicians the ability to program or upgrade the firmware/features of a DVR-
LX®/DVR/VRX1000 (VR) without physically connecting the devices to a computer.

Figure 1 — No Physical Connection to VR

The RM-OTAP feature leverages off the APX™ Radio Management application.
Firmware & configuration files are pushed to the VR via Mobile Subscriber Unit (MSU)

through any of the following mediums:

1. Wi-Fi
2. P25 (LMR)
3. USB (or USB connected to LTE device/modem)

(()

LTE

Radio Management

P25

1z | (I

o

Figure 2 — Delivery Methods for RM-OTAP

RM-OTAP is a licensed feature and can be purchased at either time of order for the VR
or purchased as a field upgrade. Please reference the Futurecom Ordering Guide by
visiting Futurecom > Support > Documentation-Software > DVRS-VRX1000
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2. Feature Requirements

Vehicular Repeater (VR): DVR-LX®, DVR and VRX1000

VR Configuration Tool: Tweaker 2.05 or later, FRC 1.0 or later
Radio Management (RM): R21.00.01 or later

VR Firmware: 1.60 or later
Mobile Firmware: R21.00.01 or later

VR Feature License: RM-OTAP
Mobile Feature License: DVRS MSU Operation

To verify which mobile models support firmware/configuration updates, see RM-OTAP
File Type Support

o

o

O

HELPFUL HINT

When using RM-OTAP for firmware updates, please note that firmware
compatibility is always enforced. Compatible MSU and VR firmware versions are
bundled together in the MSU firmware. If MSU is updated with a specific
firmware, compatible (bundled) VR firmware will be applied to the attached VR.
For a list of VR-MSU firmware version bundles, please reference the Futurecom
Compatibility Charts by visiting Futurecom > Support > Documentation-Software
> DVRS-VRX1000

HELPFUL HINT

Do not mix RM-OTAP configuration with FRC configuration. RM-OTAP and FRC
do not communicate and tracking configurations will be confusing. One method
must be selected.

HELPFUL HINT

After the initial launch of RM-OTAP support for the VR, there have been
subsequent enhancements to improve the user experience. Please see below
to determine what capability was introduced and when.

May 2022
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RM VERSION

DESCRIPTION

R21.00.01
(Initial Launch)

User is always required to link a dcd file with a mobile radio template

when using Radio Management.

a. With RM-OTAP feature license- linked dcd file is applied to the
VR.

b. Without RM-OTAP feature license- linked dcd file is not applied
to the VR.

R21.40.00 User no longer needs to link a dcd file when working with mobile
firmware prior to R21.00.01.
Manage->Templates->DVRS Files field, select “None” (see Section 4.3)
R23.00.00 User no longer needs to link a dcd file when they do not have RM-
OTAP feature license for VR (regardless of mobile firmware).
Manage->Templates->DVRS Files field, select “None” (see Section 4.3)
R23.00.00 User can apply an RM-OTAP license to a VR using RM.
R26.00.00 Support added for VR ID only change in SR2021.4

May 2022
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3. VR Firmware Update

When updating the MSU firmware, there is no user action required to update the VR
firmware. The VR firmware update software (DFB) is bundled with the MSU firmware and
will automatically update the VR firmware during an MSU firmware update. Please refer
to Motorola Radio Management Training if you have questions regarding an MSU update.

https://learning.motorolasolutions.com/
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4.VR Configuration Update

A VR configuration update using RM-OTAP is a four-step procedure:

Step 1: Creating a DCD file from Tweaker/FRC
e Creation of New File
e Modify an Existing File
e Bundling with License File
Step 2: Importing DCD File in RM server
Step 3: Linking the imported DCD file to an MSU template
Step 4: Selecting the template to write to MSU
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4.1 Creating a DCD File
To create a DCD file, there are two options: create a new file or modify an existing file.

NOTE: Remember to follow programming sequence outlined in VR Programming
Guidelines to ensure the MSU and VR are synchronized.

HELPFUL HINT
It is always recommended to save each DCD file to enable future configuration
changes for a particular VR(s).

Creation of New File
1. Establish communications with VR

2. Read the VR: select Repeater > Load Data from APX Repeater (F2)
3. Make configuration changes (as needed) for this new DCD file
4. Save the data as DCD: select File » DCD Files = Save DCD File
5. Enter data into Save window and click SAVE
6. Enter data into DCD Options window and click OK (Serial numbers are optional)
Configuration Data Name: Filename displayed after
— > importing into Radio Management (max 23 alphanumeric
_ _ chars)
Configuration Data Mame Description
|
List the serial numbers of the repeaters you wish to allow this DCD file to be applied to. Leave the list empty to allow Descrlptlon Addltlonal teXt to Clarlfy Content, dlsplayed
:::::ZT::Ibneunj:::i\';as”p;?;ze:;chers,) | or newlines. In PreVIeW Flle Header SeCtlon In open Flle WIndOW
Serial numbers should be written either as a single value (eg: 12345678) or as a range (eg: 1234000-1235000), The (maX 1024 a|phanumerIC Chal’S)
list below can contain a mixture of individual values and ranges.
Load TXT File
Load TXT File: Command button that loads an external
file that contains a list of the serial numbers. All data
imported will be placed into the List of Serial Numbers
field
List of Serial Numbers: List of serial numbers of the
repeaters that this DCD file should apply to. If left
BLANK, this DCD file will be applicable to all repeaters
(max 65000 alphanumeric characters)
Encryption: If custom encryption is used, loading the
e - e DCD file in FRC will require the custom password to be
passwerd [ entered (min 4, max 12 characters)
Confirm ’7
Bundle License File: Command button that selects a
Bundle License File | Mo License File bundled oK Cancel . ) A
= | e | License File to be bundled to the DCD. The text field

next to the button displays the License File to be
bundled.
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Modify an Existing File

NOTE: DPD files are not meant to be used for this purpose- only DCD files may be
modified to create another DCD file.

1. Select File > DCD Files - Load DCD File

Load DCD file

N

This action will OVERLAY the DCD file data over existing data in the application memory.

Click Continue.
Specify the DCD file location and name then click Open.
NOTE: If original DCD file was saved with a description, it will be displayed in the

Preview File Header section.

& OpenFile x .
Lookm: | s Quick access 7] «®@wm
— e
-~
* Documents Pictures
Quick access 4 OneDrive - McWane B OneDrive - M e
=3 -,
v.d 5 M L
- &l
- Trace upt
m’c Recent files (1) =
Netwosk i __Windows (CJ\DVRS-Testing | =3
File name: chmod:d _,_] : Open I
Files oftype [oco e  dey < St
™ Open as read-only
¥ Preview File Header
C:\Data\DVRS-Testing\Demo.ded:
Demo DCD File
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4. Unselect any screens with data that is not desired to be loaded and then click OK.

Select screens to load from DCD...

| Only selected screens will be updated !

*

Cancel
I

Screens :

|7 User Info

|7 Frequency Band Configuration
|v Repeater Channel Setup

[v Mobile Radio Channel Setup
Iv Hardware Setup

|v Analog setup

Iv VR Common Setup

|7 Emergency Setup

[v MSU Interface Setup

I¥ Tone Setup

Iv station ID Setup

Iv RSSI Setup

| pigital Setup

|v Msu pata

|v PsU 1Ds Allowed

I¥ VR Remote Activation IDs

Iv 16 Translation Table

|7 VRS-EP Compatible Mode: User Options
| VRS-EP Compatible Mode: User Option Tables
|v Semi Permanent Master

Iv Primary/Secondary Setup

Iv oTAP setup

5. Make configuration changes for this new DCD file.
6. Save the data as DCD: select File > DCD Files - Save DCD File
7. Enter data into Save window and click SAVE
8. Enter data into DCD Options window and click OK (Serial numbers are optional)
e Refer to Step 6 in Creation of New File
May 2022 Page 12 of 24
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License File Application

All feature license files, including the RM-OTAP license file, may be sent using RM-OTAP
by bundling with a DCD file.

A license file is bundled in as part of creation or modification of a DCD file.
See Bundle License File (DCD Options window, bottom left)

DCD Options X

Configuration Data Name Description

List the serial numbers of the repeaters you wish to allow this DCD file to be applied to. Leave the list empty to allow
this DCD file to be applied to all repeaters.

Separate serial numbers with spedal characters , ; | or newlines.

Serial numbers should be written either as a single value (eg: 12345678) or as a range {eg: 1234000-1235000), The
list below can contain a mixture of individual values and ranges.

Load TXT File

Encryption
¥ Default " Custom

Password
Confirm

Bundle License File | Mo License File bundled OK Cancel

HELPFUL HINT

Older versions of Tweaker/FRC have a separate menu option for saving
DCD files with license: select File > DCD Files = Save DCD File with
License

Bundling License to Template Files

User can bundle a license file to template file. This can be delivered to a single repeater
or fleet of repeaters via Radio Manager. Any repeater's S/N that matches a S/N in the
bundled license file will have that feature enabled and take in the configurations in the
corresponding template file.

Preview License Info Bundled to (DCD) Template File

User can bundle a license file to DCD file for deployment via Radio Management. FRC
shows preview of info prior to loading the DCD file
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Procedures:

1. Select File — DCD Files (Templates) — Load DCD File

DPD Files (Templates)
DCD Files (Templates)

EPR Files (Futurecom Support)
Import

Apply Rescue File to Repeater
Apply License File

File Repeater Application User Options

Q Futurecom Repeater Configurater 1.29 (VR) (Default) - 18032700 -

Help

> |

¥
¥

¥

Apply DCD to Repeater

Save DCD File
Load DCD File

E\Temp\18032700-P5UScan_37-ch4.dcd
E\Temp\18032700-all_lic_off.dcd

FATamn\ 18022700 AnhRRANTAD A-d

r

2. Enable checkbox Preview File Header in the Open File dialog window

v Preview File Header
.

1 Ed Open File s
Loak in: I Temp j - =5 ER-
* Name Date modified Ty~
1 [ 18032700-all_lic_off.dcd 11/25/2021 1:10 PM Dt
Quick access ]

D 18032700-DCD-1_w_2lic.decd 11/25/2021 12:41 PM Dt
= [ ] 18032700-only-RMOTAP.dcd 117192021 10:39AM Dt
Deskiop [ 18032700-PSUScan_37-ch4_w_lic.dcd 11/17/2021 3:24 PM Dt

1 - D 18032700-P5UScan_37-chd.ded 11/17/2021 2:51 PM Dt

b ™ D 18032700-PSUScan_39.decd 11/17/2021 12:05 PM Dt

] Libraries D 18032700-PSUScan.ded 11/17/2021 11:56 AM D
! D 18032700-DCD-1.dcd 11/5/2021 %17 AM D

4 D 18032700_All_Feature.dcd 11/1/2021 3:38 PM Dt

| RS [ 18116176-211027.dcd 10/27/2021 11:06 AM Dt

: @ Q 18116176-analog_5MN.ded 10/25/2021 10:11 AM Dt

P Network < &

] File name: |13032?{H}-PSUScan_E?-chd_w_Iic j Open

Fles of ype:  [DCDfile (~dod) =] Cacal |

[~ Open as read-only

[DCD Properties]

Description:
Date: Movember 17, 2021 15:11:17

" | Hardware Part Number: 7V083X03
Hardware Revision: 01.00
Serial Number: 13032700

E:\Temp Scan_37-ch4_w_lic.dcd:
Configuration Data Name: PSUScan Ch4 w lic

Application Software Part Number: 4C083%11

[License]
-Authentication: Enabled
-Ower The Air Programming: Enabled
-PSU Conventional Scan: Enabled
-SmartConnect Extension: Enabled
-GPS Driven Deactivation: Enabled

41 | 18032700

These license changes will apply only to the following serial numbers in Radio Management (RM):

~

T~

3. License enabled & corresponding S/N are shown (see purple box above)

May 2022
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Applying License to Repeater via Radio Manager

In general, repeater must have RM-OTAP license already enabled for it to support DCD
updates from Radio Manager. One exception is that user can enable RM-OTAP license
when using a bundled license file together with a DCD file update.

Note: cannot update another feature license via RM without RM-OTAP license
already enabled or included in the bundled license file

Failed Configuration = | Enable Auth lic only | 20211125-113509

Configuration Errors | LIC UPDT FAIL: RM-OTAP license installation failed

Procedures:
1. Create a DCD file on FRC with bundled license file

a) Select File — DCD Files (Templates) — Save DCD File
b) Follow prompt & specify DCD filename
c) Enter specifics about the DCD file

DCD Options X

Configuration Data Name Description

List the gerial numbers of the repeaters you wish to allow thiz DCD file to be applied to. Leave the list empty to allow
this DCD file to be applied to all repeaters.

Separate serial numbers with spedial characters , ; | or newlines.

Serial numbers should be written either as a single value (eg: 12345678) or as & range (eg: 1234000-1235000). The
list below can contain & mixture of individual values and ranges.

Load TXT File

Encryption
+ Default (™ Custom

Password
Confirm

Bundle License File ‘ Mo License File bundled oK Cancel
d) Click Bundle License File to pick up the appropriate .upf file

Import the newly created DCD file into Radio Manager

Link the DCD file to the mobile radio's corresponding Template
Schedule a Write job on RM for the mobile radio to push the update
MSU & Repeater will process the DCD update

Feature licenses specified in the bundled license file will be applied

ougaplrwN
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4.2 Importing DCD File in RM server
1. Using RM, in the Radio View, go to Settings-> Manage-> DVRS Files

Import
Export

Manage
Settings...
View tasks

Help
About...

Radio Management

Be

Alt+E
Ctri+K
F1
Alt+B

»
»
Maodel Number Template Firmware
M37TSS9PWIAN D21.15.54

» Templates Alt+T
Licenses »
Firmware Alt+F
Language Packs Alt+L
Voice Announcements Alt+V
CA Certificates Ctrl+B
DVRS Files Alt+U

2. From the DVRS Files screen, click Import (icon with three dots inside circle).

@ Radio Management

(¢ O

source View » DVRS Files

DVRS Files

Language Packs

Imported Date

14/05/2020 1038 AM 0

InvalidSeriaiNumber
Test_15May

Test
Demo_SerialNumber
Demo_hashUpdate
VRX-Test

Demo-Test
FeatureUpgrade

dcd1 22

InValidsN

test]

ValidSN
FeatureUpgradeScanOff2

18PM
14/05/2020 4:20 PM
15/05/2020 243 PM
21/05/2020 1:56 PM
15/06/2020 9:50 AM
15/06/2020 9:58 AM

©co0 0000

17/06/2020 1048 AM O
18/06/2020 11:16 AM 0

18/06/2020 1:42 PM
23/06/2020 222 PM

0
0

07/06/2020 1241 PM 0
07/06/2020 1241 PM 0
07/06/2020 1241 PM 2

07/06/2020 1:39 PM

1

15 items found (0 currently selected),

In-Use Templates

and Radios

~~ocococococooo0o0o0o0o0o

in-Use Templates (Tempiate M}

3. Select the DCD file previously saved from Tweaker/FRC and click open.

4. Inthe Job View, confirm the DCD file has imported successfully.

HELPFUL HINTS

It is always recommended to use a new DCD file name. When reusing an
existing DCD file name, delete first from DVRS Files view in Radio
Management (pictured above) to ensure it will be properly imported.

Also note that a DCD created prior to FRC 1.18 cannot be used.

May 2022
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4.3 Linking the Imported DCD file to an MSU template

1. To associate the DCD file with a specific MSU connected to the VR, navigate to
Settings->Manage->Templates.

—
{fi Radio Management
B
Import »
Export »
Size(KB)
OtapTest 7
Manage » Templates Alt+T
Settings... Alt+E Licenses »
View tasks Ctri+K Firmware Alt+F
Help F1 Language Packs Alt+L
About... Alt+B Woice Announcements Alt+V
CA Certificates Ctri+B
DVRS Files Alt+U
NMamaA_Tack E

2. Select the MSU template and scroll to the right and locate the "DVRS File"
column and select the DCD file from the drop-down menu.

(R Radio Management

- a X
2 J©) FIRREREIE
Template View
S ® O -

Model Number ~ Template Firmware Version

681CTZ2196(21) M37TSSOPWIAN  D21.1554

English Vv ~ 0 Voic ents R2
APX8500 KSP-ROAD 1.6(1) M37TXS9PWIAN  R21.03.00 lish None ~ 2Voice Announcements R2
P 681CTZ2196(21)_200706_12555704 M37TSSOPWIAN  D21.1554 lish Demo-Test 5] ovoice Announcements Rz

FeatureUpgrade
ded1 22

InValidSN
test]

3 items found (0 currently selected).

Tasks(10*)

HELPFUL HINT

If DCD file does not appear as expected in the DVRS File drop down menu,

one possible solution is to export mobile xml to FRC, save DCD, and import
DCD into RM again.
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4.4 Selecting the Template to Write to MSU

1. Before scheduling the job, in the Radio View, confirm the VR ID is correct in the
"VR ID" column.
Note: The purpose of having the VR ID as a separate column for each radio is
that the DCD is a template to be used for multiple radios and does not contain
the VR ID.

Radic Management

Radio View

Show Details... Schedule Job... |
S PDO00QHHE a -

Serial Number ~ Model Number ~ Codeplug Version ~ Firmware Version ~ FLASHcode
681CVKE918 MI7TXSOPWIAN R21.00.07 R21.03.00 98XY8g-89HE80-3-000000-00000(
»  B8ICTZ2196 M3I7TSSOPWIAN R21.00.01 D21.15.54 10X048-097490-0-000000-000000\:

HELPFUL HINT
VR ID- displayed in Hex- if you enter VR ID as decimal, it will automatically
convert to hex.

HELPFUL HINT

VR ID Change Only: To change the VR ID only, a DCD must still be attached
to the job even if there are no configuration changes. An attempt to change
the VR ID without an attached DCD will have no effect. If NONE is selected,
RM will block with a pop-up error message and revert the VR ID.

Error >

A [#2049] VR ID cannot be changed since the radio’s template doesn't
have a DVRS file assigned.

2. Right click on the row and schedule a write job to complete the configuration
update on the VR.
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Radio Management = [m} X
ﬂ @ BET|TE T
Radio View
Show Details... Schedule Job...
Al
P CECNCN ] Q- i
Serial Number Model Number Codeplug Version Firmware Version FLASHcode VRID ¥ Md
681CVK6918 M37TXS9PWIAN R21.00.01 R21.03.00 98XY8g-89H680-3-000000-000000 0x100
> 681CTZ2196 M37TSSOPWIAN R21.00.01 D21.15.54 IOXM—OQMW»G-OMOD»WOOW? [))(‘IO.E L}

3. Proceed to Job View to see the status of the configuration update. Once it is
shown as complete in the job status column, the MSU control head will display
"Updating DVRS" and restart.
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4.5 How to Initiate Automatic Update for a Replacement VR
Prerequisite*:

¢ RM-OTAP must have been successfully used to send firmware and
configuration to the VR being replaced

1. Remove old VR from installation.
2. Prepare new VR by installing RM-OTAP license via FRC (See License File
Application).
3. Connect new VR to original MSU.
4. Power up original MSU & new VR.
e Observe DVRS Update
e Firmware version bundled inside MSU will be pushed to VR
e If MSU has previously saved configuration, that will be pushed to VR as
well
e VR ID is updated
5. MSU will reset.

*|f prerequisite is not met, refer to Section 4.5 Error! Reference source not
found..
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4.6 How to Overwrite a Temporary Configuration or Firmware
Update for a VR

Prerequisites:

e RM-OTAP must have been successfully used to send firmware and
configuration to the VR

¢ Firmware and/or configuration and/or VR ID have been updated using FRC
after RM-OTAP was last used

To restore VR to last configuration and firmware sent using RM-OTAP:
1. Connect laptop to new VR via USB programming cable.

2. Launch FRC.
3. Goto Update Info screen.

Update Info

g
EREEREE =

MName Timestamp Access Time CRC
Local Configuration = | | | 2021-10-23 10:14:21 |
Local Firmware = I | [ 2021-11-05 09:23:41 |
QTAP Configuration = | DCD-1 | 2021105031734 | | 876ebd4d
OTAP Firmware = | APXDVR-17D-5028 | 20211015-161804 | | 7e63a8ef
Last Configuration = MsL Reload OTAP Configuration from MSU |
legs ez I Loczl Reload OTAP Firmware from MSU |

e Click Reload OTAP Configuration from MSU button.
e Click Reload OTAP Firmware from MSU button.
4. Power down VR.
5. Power up MSU & VR.
o Observe DVRS Update (applicable when swapping in new repeater with
RM-OTAP license enabled).
Firmware version bundled inside MSU will be pushed to VR.
¢ |f MSU has previously saved configuration, that will be pushed to VR as
well.
e VRID is updated.
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5. Licensed Feature Upgrade

If a feature has been purchased from Futurecom (i.e. Authentication), a license file is
provided by Futurecom. To bundle this file with a DCD, refer to Section 4.1 License File
Application
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6. RM-OTAP File Type Support

VR Configuration and License Files

VR Remote Configuration and License File Updates (RM R21.00.00)

MSU Models Transport Method (RM to MSU)
(AN/BN)

USB WiFi P25 (LMR)

APX 7500AN Supported Not Supported Supported
APX 6500AN
APX 4500AN
APX 2500AN

APX 8500 Supported Supported Supported
APX 6500BN
APX 4500BN
APX 2500BN

VR Firmware

VR Remote Firmware Update (RM R21.00.00)

MSU Models Transport Method (RM to MSU)
(AN/BN)

USB WiFi P25 (LMR)

APX 7500AN Not Supported Not Supported Not Supported
APX 6500AN
APX 4500AN
APX 2500AN

APX 8500 Supported Supported Supported
APX 6500BN
APX 4500BN
APX 2500BN

NOTE: Not all above model pairings are offered in all regions.
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7. Contact Information

Subscribe to our newsletter if you want to be informed about new releases and updates.
Please visit http://futurecom.com/support/newsletter/

= FUTURECOM

®
SYSTEMS G O uU?P ULC

Futurecom Systems Group, ULC.
3277 Langstaff Rd
Concord, Ontario L4K 5P8
Canada
1-800-701-9180
https://www.futurecom.com/

© 2021 Futurecom Systems Group, ULC
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